Настраиваем VLAN на коммутаторах Акманай 2424GE-S


Опубликовано 16.10.2020 14:34 | Автор: Admin
Данная публикация была обновлена 12.10.2021 15:37

В данной статье рассматривается:
Рассмотрим, как настроить на коммутаторах Акманай 2424GE-S VLAN, MAC-VLAN, VOICE-VLAN, LACP, рассмотрим работу с портами в режиме access, trunk, general. Поработаем с LLDP и DHCP для автонастроки IP телефонов.

Все настройки я буду делать исключительно из командной строки, но на коммутаторе имеется простенькая WEB которая позволяет произвести базовые настройки.

Версия прошивки:

  Version: 5.5.1.17_plgn

  Date: 07-Sep-2020


Почитать что такое VLAN читать

Ознакомиться c первоначальные настройки коммутатора Акманай 2424GE-S.


По умолчанию все порты на коммутаторе являются членами VLAN1. Таким образом, все порты на устройстве составляют один широковещательный домен. Когда вы помещаете тот или иной порт в VLAN, то этот порт автоматически удаляется из VLAN по умолчанию.

На коммутаторе можно использовать в качестве индификаторов VLAN ID от 1 до 4094 

Для того чтоб машины из одного vlan могли видеть машины из другого vlan необходимо настроить маршрутизацию между ними – это можно сделать, используя функции L3 коммутатора или же использованием внешнего маршрутизатора.

Каким у нас может быть порт:

  • access (Членом того или иного VLAN)порт принадлежащий одному VLAN’у и передает нетегированный трафик. Все устройства в одном VLAN видят только тех, кто находиться в том же VLAN. Если у вас есть VLAN 1 и VLAN 2 то устройства в VLAN 1 не будут видеть VLAN 2 и на оборот.
  • trunk (Тегированным/транковым)порт, передающий/принимающий тегированный трафик одного или нескольких VLAN’ов. Этот порт лишь пропускает кадры с тегами, которые разрешены на этом порту. Обычно используется для соединения коммутаторов на которых имеются vlan.
  • generalработает по принципу что и trunk порт, но со своими особенностями. Обычно используется для подключений IP телефона и компьютера в одну розетку. Где телефония идет как тегированный трафик, а компьютер нетегированный трафик.

Дополнительно:

voice vlan - голосовой VLAN используется для изоляции голосового трафика от данных

mac-vlan - настроев данный функционал мы получим возможность исходя из mac устройства направить его трафик в тот или иной vlan и задать нужный приоритет.

LLDP - протокол канального уровня, позволяющий сетевому оборудованию оповещать оборудование, работающее в локальной сети, о своём существовании и передавать ему свои характеристики, а также получать от него аналогичные сведения.

Порты именуются следующим образом

GE 1/2/3

где:

1номер юнита в стеке. При отсутствии стека он всегда равен 1

2номер модуля в коммутаторе, для физических портов он равен 0

3непосредственно номер порта на выбранном модуле.

Манипулировать VLAN мы можем как отдельно с каждым, так и группой.

При выполнении команд обращайте на тот режим в котором вы находитесь

console> - обычные пользовательский режим
console#  - привилегированный режим(режим с повышенным правами)
console(config)#  - режим конфигурирования


Создание/удаление VLAN

!входим в режим конфигурирования
console#configure
!входим в режим манипулирования Vlan
console(config)#vlan database
!создаем vlan с номерами 5,7 и с 50 по 60
console(config-vlan)#vlan 5,7,50-60
!удалим vlan с 50 по 60
console(config-vlan)#no vlan 50-60

!Так же мы можем создать Vlan по иному.
console(config)#vlan 6,8,60-70
!удалим vlan
console(config)#no vlan 6,8,60-70

!создание влан c именем
console(config)#vlan 100 name test

!задать имя на уже имеющимся VLAN
console(config)#interface vlan 100
console(config-if)#name sotka


Добавление/удаление портов из VLAN

Порты access могут быть членами только одного из влан.

!входим в режим конфигурирования
console#configure
!входим в режим конфигурирования интерфейса (порта) 1
console(config)#interface GE 1/0/1
!добавляем порт 1 в влан 10 
console(config-if)#switchport access vlan 10
!удаляем порт 1 из влан 10. Порт становиться членом VLAN по умолчанию 
console(config-if)#no switchport access vlan
!входим в режим конфигурирования интерфейса (порта) 1 и портов с 5 по 10 
console(config)#interface range GE 1/0/1,GE 1/0/5-10
!добавляем данные порты в влан 20 
console(config-if-range)#switchport access vlan 20
!удаляем данные порты из влан 20 
console(config-if-range)# no switchport access vlan


Работа с TRUNK (танковыми) портами

При работе порта в режиме TRUNK по умолчанию всему трафику РАЗРЕШЕНО ходить во все имеющиеся VLAN на коммутаторе. Данные порты обычно используются для соединения коммутаторов между собой.

!входим в режим конфигурирования
console#configure
!входим в режим конфигурирования интерфейса (порта) 23
console(config)#interface GE 1/0/23
!говорим, что порт будет работать в режиме trunk. 
!При этом по умолчанию тегированный трафик будет хоть во все доступные vlan.
console(config-if)#switchport mode trunk
!задать vlan по умолчанию, куда будет идти весь трафик что не имеет меток
console(config-if)#switchport trunk native vlan 100
!дополнительно
!запретить приходящему трафику ходить в  vlan 110
console(config-if)#switchport trunk allowed vlan remove 110
!запретить приходящему трафику ходить в  vlan 20 и 110
console(config-if)#switchport trunk allowed vlan except 20,110
!если мы ранее удалили VLAN из разрешенных, то вернуть можно
console(config-if)#switchport trunk allowed vlan add 110
!очистить все исключения
console(config-if)#no switchport trunk allowed vlan

Работа с GENERAL портами

При работе порта в режиме GENERAL по умолчанию всему трафику ЗАПРЕЩЕНО ходить в любой имеющейся VLAN на коммутаторе. Данные порты обычно используются для подключения IP телефонов и компьютера на один порт.

!входим в режим конфигурирования
console#configure
!входим в режим конфигурирования интерфейса (порта) 3
console(config)#interface GE 1/0/3
!говорим, что порт будет работать в режиме general. 
!При этом по умолчанию тегированный трафик будет хоть только в разрешенные vlan.
console(config-if)#switchport mode general
!разрешаем ходит тегированному трафику в vlan 20 и 30.
!По умолчанию метки снимаются
console(config-if)#switchport general allowed vlan add 20,30
!задаем VLAN по умолчанию, куда будет ходить весь не тегированный трафик
!данный VLAN должен быть разрешен в  allowed vlan
console(config-if)#switchport general pvid 20
!дополнительно
!удаляем все разрешения на доступы к VLAN
console(config-if)#no switchport general allowed vlan
!удаляем VLAN 20 из разрешенных на порту
console(config-if)#switchport general allowed vlan remove 20


Настройка порта для работы с MAC-VLAN

Данная конфигурация позволит нам на основе mac адреса устройства поместить его в тот или иной VLAN. Может использоваться для подключения IP телефонов и компьютера на один порт. Для телефонов что не поддерживают VLAN или по иным причинам.

Порт в режиме работы GENERAL

!входим в режим конфигурирования
console#configure
!входим в режим манипулирования с Vlan
console(config)#vlan database
!создаем влан 10,40,110
console(config-vlan)#vlan 10,40,110
!определяем шаблон-маску mac по которой мы будем определять наши устройства. 
console(config-vlan)#map mac 64:c3:54:00:00:00 24 macs-group 1
!входим в конфигурирования интерфейса 17
console(config)#interface GE 1/0/17
!задаем режим работы порта как general
console(config-if)#switchport mode general
!разрешаем ходить тегированную трафику в vlan 10 и 110, метки тега снимаем
console(config-if)#switchport general allowed vlan add 10,110 untagged
!определяем на интерфейс правило отбора в vlan 110 по шаблону mac
console(config-if)#switchport general map macs-group 1 vlan 110
!задаем vlan по умолчанию, куда будет помещен не тегированный трафик
console(config-if)#switchport general pvid 10

Теперь коммутатор увидев совпадение заданного mac адреса в пакете, направит этот пакет в указанный нами VLAN.


Настройка VOICE VLAN и LLDP для IP телефонов

VOICE VLAN – позволяем нам выделить голосовой трафик и обеспечить его качеством. Данная функция работает на основе OUI устройства и когда на порту будет замечен указанный oui, то данный порт будет добавлен в голосовой влан как тегированный. 

LLDP – в данном контексте, передаст настройки на наш IP телефон с которыми он должен работать, в частности vlan и приоритет. Для получения настроек подключаемые телефоны должны поддерживать расширенный протокол LLDP MED, а так же уметь работать с VLAN. 

VOICE VLAN по факту работает на основе LLDP, но со  своими отличиями. Коммутатор мы можем настроить на работу сразу по двум правилам VOICE VLAN + LLDP или же использовать их отдельно.

Подключаемые телефоны не должен иметь статически вбитых настроек таких как: IP телефона, шлюза, IP сервера и т.д. 

В примере VLAN 110 - для голоса, VLAN 10 для данных от компьютера

Для полноценной автонастройки телефона требуется так же настроить DHCP сервер.

Настройка коммутатора на работу с VOICE VLAN по его OUI

Баг: на данной версии прошивки.

VOICE VLAN работает на основе OUI и когда он видит совпадения в кадре mac адреса источника, то передает необходимые настройки для телефона по протоколу LLDP. Эти настройки определены производителем коммутатора. VOICE VLAN не будет работать с телефонами, что не поддерживают vlan и LLDP.

!входим в режим конфигурирования
console#configure
!создаем vlan 10,110
console(config-vlan)#vlan 10,110
!указываем ID голосового VLAN
console(config)#voice vlan id 110
!определим cos для голосового трафика, чем выше тем больший приоритет. По умолчанию 6.
!в общем-то данную команду пропускаем
console(config)#voice vlan cos 4
!включаем работу портов voice vlan по таблице oui
console(config)#voice vlan state oui-enabled
!добавить в таблицу oui идентификатор голосового устройства,
!в качестве него выступает первые три октета mac адреса устройства (ID производителя)
console(config)#voice vlan oui-table add 64c354 Avaya
!входим в режим конфигурирования интерфейса (порта) 17
console(config)#interface GE 1/0/17
!задаем режим работы порта general
console(config-if)# switchport mode general
!разрешаем ходить тегированную трафику в vlan 10 (компьютер), метки тега снимаем
console(config-if)#switchport general allowed vlan add 10 untagged
!разрешаем ходить тегированную трафику в vlan 110 (голос), метки тега не снимаем 
console(config-if)#switchport general allowed vlan add 110 tagged
!задаем vlan по умолчанию, куда будет помещен не тегированный трафик
console(config-if)#switchport general pvid 10
!включаем голосовой трафик на порту
!именно после данной команды коммутатор начнет анализировать трафик на порту на наличие
!mac адреса устройства и помещать фреймы в нужный VLAN
console(config-if)# voice vlan enable

После данной настройки коммутатор будет сообщить телефону исходя из его OUI настройки с которыми он должен работать, а так же обеспечивать приоритет трафика.

Если брать коммутаторы других брендов, то данная настройка должна помещать трафик в нужный влан оперируя OUI в независимости от наличия в телефоне поддержки LLDP и VLAN. Производитель этот момент проигнорировал. 

Настройка коммутатора для передачи данных телефону по протоколу LLDP

В отличии от VOICE VLAN мы можем создать свои правила игры и передавать иные настройки на телефон. При этом не заморачиваться с MAC телефонов.

В данном случае коммутатор по протоколу lldp сам понимает, что к нему подключили телефон и сообщает ему настройки с которыми он должен работать.

!входим в режим конфигурирования
console#configure
!создаем vlan 10,110
console(config-vlan)#vlan 10,110
!настройка lldp на передачу данных на телефон
!отключаем работу по автоматическим политикам 
console(config)#no lldp med network-policy voice auto
!создаем свою политику. 
!Задаем номер политики 1, указываем ID 110 голосового vlan,
!говорим что порт должен быть тегированным, задаем приоритет пакетов 6.
!Так же можно назначить DSCP
console(config)#lldp med network-policy 1 voice vlan 110 vlan-type tagged up 6
!входим в режим конфигурирования интерфейса (порта) 17
console(config)#interface GE 1/0/17
!задаем режим работы порта general
console(config-if)# switchport mode general
!разрешаем ходить тегированную трафику в vlan 10, метки тега снимаем
console(config-if)#switchport general allowed vlan add 10 untagged
!разрешаем ходить тегированную трафику в vlan 110, метки тега не снимаем
console(config-if)#switchport general allowed vlan add 110 tagged
!задаем vlan по умолчанию, куда будет помещен не тегированный трафик
console(config-if)#switchport general pvid 10
!подключаем выше созданную политику, для передачи на устройство
console(config-if)#lldp med network-policy add 1
!Включаем работу политик на порту. Не обязательно, но если не работает, то делаем. 
console(config-if)#lldp med enable network-policy

После данной настройки коммутатор сообщит телефону как ему надо работать с портом. Соответственно порт мы так же настроили на работу по тем настройкам что передаем.

Дополнительно:

!Проверка что lldp med работает 
console# show lldp med configuration ge 1/0/17

!Узнать информацию о устройстве
console# show lldp neighbors ge 1/0/17

!Узнать настройку порта
console#show lldp local ge 1/0/17

!проверка работы голосового vlan
console(config-if)#do show voice vlan type oui ge 1/0/17


Настройка DHCP сервера

Настроим DHCP сервер на голосовом VLAN (110) с передачей настроек для IP телефона Avaya 1600 серии.

!входим в режим конфигурирования
console#config
!входим в конфигурирования интерфейса VLAN 1
console(config)#interface vlan 1
!отключаем автоматическое получение IP адреса от DHCP
console(config-if)#no ip address dhcp
!выходим из текущего режима
console(config-if)#exit
!включаем DHCP сервер
console(config)#ip dhcp server
!создаем пул DHCP сервера и входим в конфигурирование его
console(config)#ip dhcp pool network VOICE
!задаем диапазон выдачи адресов для клиентов
console(config-dhcp)# address low 192.168.10.10 high 192.168.10.254 255.255.255.0
!задаем шлюз для клиентов
console(config-dhcp)#default-router 192.168.10.1
!задаем DNS сервер для клиентов
console(config-dhcp)#dns-server 192.168.10.1
!задаем время жизни аренды
console(config-dhcp)#lease 5
!задаем опцию по которой телефоны будут получать свои настройки
!для телефонов Avaya 1600 серии она равна  242
!в нормальном виде выглядит так MCIPADD=0.0.0.0,HTTPSRVR=0.0.0.0,HTTPDIR=0.0.0.0
!но нам данную настройку необходимо перевести в HEX
!можно написать option 242 ascii “бла бла” – но в данном коммутаторе это не получится 
console(config-dhcp)#option 242 hex 4d4349504144443d302e302e302e302c48545450535256523d302e302e302e302c485454504449523d302e302e302e30
!выход из текущего режима
console(config-dhcp)#exit
!заходим в конфигурирование vlan 110,  наш голосовой влан
console(config)#interface vlan 110
!назначаем IP адрес на интерфейс, по нему DHCP сервер будет выдавать IP адреса для клиентов
console(config-if)#ip address 192.168.10.2 255.255.255.0

Настройка агрегации (LACP) портов

Произведем агрегацию портов по технологии LACP, коммутаторы находятся в стеке, возьмем 10G - TE1/0/3 порт на 1 юните и 10G - TE4/0/3 порт на 4 юните.

!создаем группу агрегирования с id 1
console(config)#interface Port-Channel1
!говорим, что группа будет работать в режиме транк
console(config-if)#switchport mode trunk

!входим в режим конфигурирования интерфейса (порта) 1/0/3
console(config)#interface TengigabitEthernet1/0/3
!задаем группу агрегирования 1 созданную ранее
!режим работы порта берется от группы
!mode auto - именно для LACP
console(config-if)#channel-group 1 mode auto

!входим в режим конфигурирования интерфейса (порта) 4/0/3
console(config)#interface TengigabitEthernet4/0/3
!задаем группу агрегирования 1 созданную ранее
!режим работы порта берется от группы
console(config-if)#channel-group 1 mode auto

Дополнительно:

Если вы получили ошибку:

DHCP server cannot be configured. To enable the DHCP server, remove DHCP clients on all interfaces.

то необходимо отключить клиента на VLAN 1

console(config)#interface vlan 1
console(config-if)#no ip address dhcp

!посмотреть что выдалось
console(config)#do sh ip dhcp binding



Метки
Коммутатор Акманай VLAN Сети

Комментариев: 0

 67 |


Добавить комментарий:
Google
Yandex
Отправить