Настраиваем VLAN на коммутаторе Арлан 3424GE-S


Опубликовано 03.12.2020 16:39 | Автор: Admin

В данной статье рассматривается:
В данной статье мы рассмотрим, как создаются VLAN на коммутаторе Арлан-3424GE-S, а также кратко рассмотрим работу с портами в режиме access, trunk. Настроим DHCP и Voice vlan на примере, где на одном порту будет работать телефон и компьютер, но в разных VLAN. Создадим агрегацию портов LACP

Прежде чем настраивать VLAN хорошо бы ознакомиться с Первоначальная настройка коммутатора Арлан 3424GE-S

Все настройки я буду делать исключительно из командной строки, но все это можно сделать и через WEB интерфейс.  

Информация о настройках по умолчанию

По умолчанию все порты на коммутаторе являются членами VLAN1 по умолчанию. Когда вы помещаете тот или иной порт в VLAN, то этот порт автоматически удаляется из VLAN по умолчанию.

На коммутаторе можно использовать в качестве индификаторов VLAN ID от 1 до 4094. Коммутатор поддерживает настройку до 256 VLAN.

Для того чтоб машины из одного vlan могли видеть машины из другого vlan необходимо настроить маршрутизацию между ними – это можно сделать, используя функции L3 коммутатора или же использованием внешнего маршрутизатора.

Каким у нас может быть порт:

  • access (Членом того или иного VLAN)порт принадлежащий одному VLAN’у и передает/пирнимает нетегированный трафик. Все устройства в одном VLAN видят только тех, кто находиться в том же VLAN. Если у вас есть VLAN 1 и VLAN 2 то устройства в VLAN 1 не будут видеть VLAN 2 и на оборот.
  • trunk (Тегированным/транковым)порт передающий тегированный трафик одного или нескольких VLAN’ов. Этот порт лишь пропускает кадры с тегами, которые разрешены на этом порту. Похож на железнодорожную развилку, в которой ваше дальнейшее движение определяется наличием путей (VLAN), а также наличия у вас документов, которые, скажут стрелочнику куда вас отправить. Если вы без документов, то вас сбросят с путей, чтоб не мешались. Одновременно на развилку может приходить поезда едущий в разных направлениях т.е. на порту может одновременно ходить трафик для разных VLAN. Обычно используется для соединения коммутаторов в которых имеются vlan.
  • customer - всегда добавляет тег в отправляемые пакеты и удаляет тег из принимаемых пакетов. На интерфейс коммутируются только пакеты с номером тега customer-VLAN интерфейса Ethernet. Тип протокола в добавляемом теге – 0х8100


Порты именуются следующим образом:

gigabitethernet0/1 или Gi0/1

tengigabitethernet0/1 или Te0/1

где:

  •  0 – номер коммутатора в стеке
  •  1 – непосредственно номер порта на выбранном модуле.


Манипулировать VLAN мы можем как отдельно с каждым, так и группой. 

При выполнении команд обращайте на тот режим в котором вы находитесь

admin@Switch>- обычные пользовательский режим
admin@Switch#  - привилегированный режим(режим с повышенным правами)
admin@Switch(config)# - режим конфигурирования

Чтоб нас во время настройки не донимало завершение сессии выполним следующую команду:

admin@Switch# terminal session-timeout 0  

Создание/удаление VLAN 

!входим в режим конфигурирования
admin@Switch# configure terminal
!создаем vlan с номерами 10,20 и с 30 по 40
admin@Switch(config)# vlan 10,20,30-40
!выходим из текущего режима
admin@Switch(config-vlan)# exit
!удалим vlan 10
admin@Switch(config)# no vlan 10
!создаем или входим vlan с номером 20
admin@Switch(config)#vlan 20
!задаем имя vlan как test
admin@Switch(config-vlan)# name test


Добавление/удаление портов из VLAN

Порты access могут быть членами только одного из влан.

!входим в режим конфигурирования
admin@Switch# configure terminal
!входим в режим конфигурирования интерфейса (порта) 1
admin@Switch(config)# interface gigabitethernet0/1
!добавляем порт 1 в влан 10
admin@Switch(config-if)# switchport access vlan 20
!удаляем порт 1 из всех влан
admin@Switch(config-if)# no switchport access vlan
!входим в режим конфигурирования интерфейсов (портов)1,5, 10 по 15 
admin@Switch(config)# interface range gigabitethernet0/1,gigabitethernet0/5,gigabitethernet0/10-15
!удаляем порты 1,5, 10 по 15 из всех влан
admin@Switch(config-if-range)# no switchport access vlan
!выходим из текущего режима
admin@Switch(config-if-range)# exit


Работа с TRUNK (танковыми) портами

При работе порта в режиме TRUNK по умолчанию всему трафику НЕ РАЗРЕШЕН доступ к имеющимся vlan на коммутаторе.

!входим в режим конфигурирования
admin@Switch# configure terminal
!входим в режим конфигурирования интерфейса (порта) 10
admin@Switch(config)# interface gigabitethernet0/10
!или же в сокращенном виде
admin@Switch(config)# interface gi0/10
!говорим, что порт будет работать в режиме trunk. 
!При этом по умолчанию тегированному трафику запрещено ходить не в один из существующих влан.
admin@Switch(config-if)# switchport mode trunk
!разрешаем тегированному трафику ходить только в 40 vlan 
admin@Switch(config-if)# switchport trunk allowed vlan add 40
!разрешаем тегированному трафику ходить только в 30, 31, 35 по 40 vlan 
admin@Switch(config-if)# switchport trunk allowed vlan add 30,31,35-40
!убираем разрешение тегированному трафику ходить в 40 vlan
admin@Switch(config-if)# switchport trunk allowed vlan remove 40
!удаляем все имеющиеся разрешения на доступ к vlan
admin@Switch(config-if)# switchport trunk allowed vlan remove all
!задать vlan по умолчанию, куда будет идти весь трафик что не имеет тега
admin@Switch(config-if)# switchport trunk native vlan 10
!удаляем правило для native vlan
admin@Switch(config-if)# no switchport trunk native vlan
!удаляем режим работы порта
admin@Switch(config-if)# no switchport mode


Дополнительно:

!посмотреть статус портов
admin@Switch(config)# show interfaces status
!посмотреть членство портов в vlan
admin@Switch(config)#  show vlan
!посмотреть информацию о настройке порта
admin@Switch(config)# show interfaces gi0/1


Настрока DHCP, LLDP,  VOICE VLAN

Пример настройки коммутатора на работу с телефонам и компьютером подключенным в один порт.

В качестве подопотного телефона выступал QTECH QVP-100.

Настроим DHCP и Voice vlan, где наш телефон получит следующие настройки:

  •  - по протоколу LLDP получит vlan для голоса, настроит политики для голосового трафика
  •  - по DHCP получит IP, шлюз, днс сервер

Компьютер подключается в соответствующий порт на телефоне, а телефон к коммутатору.

Первым делом создаем VLAN для голоса и для компьютера

!входим в режим конфигурирования
admin@Switch# configure terminal 
!создаем vlan 110 для голоса и 100 для компьютера
admin@Switch(config)# vlan 110, 100 
!выходим из текущего режима
admin@Switch(config-vlan)# exit

Устанавливаем IP адрес на vlan в котором будет работать наш DHCP сервер. Для голоса я буду использовать 110 vlan. Без установки этого IP адреса выдаваться не будут.

!входим в режим конфигурирования
admin@Switch# configure terminal
!входим в режим настройки интерфейса vlan 110
admin@Switch(config)# interface vlan 110
!задаем IP адрес на данный интерфейс
admin@Switch(config-if-vlan)# ip address 192.168.100.2 /24
!выходим из текущего режима
admin@Switch(config-if-vlan)# exit

Настраиваем DHCP сервер для выдачи адресов 

!входим в режим конфигурирования
admin@Switch# configure terminal
!создаем пул DHCP с именем mypool
admin@Switch(config)# ip dhcp pool network mypool
!задаем диапазон ip адресов которые может выдавать данный сервер
admin@Switch(config-dhcp-network)# address low 192.168.100.10 high 192.168.100.250 /24
!задаем шлюз который будет передавать наш DHCP сервер клиентам
admin@Switch(config-dhcp-network)# default-router 192.168.100.50
!задаем DNS сервер который будет передавать наш DHCP сервер клиентам
admin@Switch(config-dhcp-network)# dns-server 192.168.100.10
!выходим из текущего режима
admin@Switch(config-dhcp-network)# exit
!запускаем DHCP сервер
admin@Switch(config)# ip dhcp server

Включаем функцию Voice VLAN на порту. 

При включении Voice VLAN на порту коммутатор автоматически производит следующие настройки:

Добавляет две сетевые политики LLDP-MED для этого порта со следующими параметрами:

  •  Application: voice и voice-signaling;
  •  VLAN ID: равен номеру Voice VLAN, настроенному на порту;
  •  Layer 2 priority: 5; • DSCP: 46; 2. Добавляет порт в Voice VLAN;
  •  Устанавливает режим QoS “trust cos” на порту

QoS и LLDP по умолчанию включены.

mls qos trust device ip-phone - для исключения возможности использования высокого приоритета при прямом подключении рабочей станции к устройству в обход IP-телефона.

При данной настройки трафик на порту 1 с телефона будет направлен в vlan 110, а трафик с компьютера в vlan 100

!входим в режим конфигурирования
admin@Switch# configure terminal
!переходим в режим конфигурирования интерфейса 0/1 -  порт 1 
admin@Switch(config)# interface gigabitethernet0/1
!задаем vlan для порта, в этот влан будет направлен весь трафик без тега т.е. трафик компьютера
admin@Switch(config-if)# switchport access vlan 100
!задаем vlan в который будет направляться трафик от телефона
!при этом будут созданы соответствующие политики и т.д. 
admin@Switch(config-if)# switchport voice vlan 110
! включения проверки подключения IP-телефона на порту
admin@Switch(config-if)#  mls qos trust device ip-phone

Дополнительно

!посмотреть конфигурацию lldp
admin@Switch(config)# show lldp configuration
!посмотреть обнаруженные устройства по протоколу lldp
admin@Switch(config)# show lldp neighbors
!посмотреть выданные IP адреса
admin@Switch(config)# show ip dhcp binding
!удалить аренду IP адреса 192.168.100.10
admin@Switch# clear ip dhcp binding 192.168.100.10


Настройка агрегации (LACP) портов

Произведем агрегацию портов по технологии LACP, коммутаторы находятся в стеке, возьмем 10G - TE1/1 (24) порт на 1 юните и 10G - TE2/1 (24) порт на 2 юните.

Назначение режимов работы для портов в агрегации необходимо назначать на группу агрегации, эти настройки сами подтянутся в конфигурацию портов. 

!входим в режим конфигурирования
admin@Switch# configure terminal
!переходим в режим конфигурирования группы агрегации id 1 
admin@Switch(config)#interface portchannel1
!говорим, что порты в группе будут работать в режиме транк
admin@Switch(config-if)#switchport mode trunk
!разрешаем работу со всеми влан
admin@Switch(config-if)#switchport trunk allowed vlan add 1-4094
!переходим в режим конфигурирования интерфейса 
admin@Switch(config)# interface tengigabitethernet1/1
!задаем принадлежность порта к группе агрегирования 1, режим LACP active
admin@Switch(config-if)# channel-group 1 active
!переходим в режим конфигурирования интерфейса 
admin@Switch(config)# interface tengigabitethernet2/1
!задаем принадлежность порта к группе агрегирования 1, режим LACP active
admin@Switch(config-if)# channel-group 1 active

Дополнительно

!посмотреть информацию как у нас собрался LACP
admin@Switch#show lacp port-channel 1

Метки
Коммутатор Арлан VLAN Сети

Комментариев: 0

 88 |


Добавить комментарий:
Google
Yandex
Отправить